Thursday, January 30, 2014

Blog: Blogger should be renamed BDSM Flogger

I was checking the iTunes App Store to see if google had released a new version of the blogger app. The current version is buggy, limited, and serves little purpose outside the realm of a simple text editor.

I found myself surprised, noting that the version I have from May 2013 was supposed to include horror and fear, prolonged graphic and sadistic violence, and much more...

I feel like I must have overlooked these features, though infrequent, I should at least know where they are activated.


1 comment:

Because spammers suck, all comments are moderated.
Please do not let this deter you from interaction.
Thanks!